Auch wenn ich der Meinung bin, dass Meine_Klassen  erst bei Geräten mit HiRes richtig sinnvoll eingesetzt werden kann, kann man das Programm auch auf Geräten mit  "kleineren" OS-Versionen benutzen. Neben dem damit verbundenen Verzicht auf einige Funktionen (Schriftgrößen einstellen, Benutzung des Sitzplanes ist mit großer Schriftart sicherlich nicht sinnvoll ...) gibt es hier aber auch ein Problem mit dem zur Verfügung stehenden Speicherplatz der Geräte (dynamic heap).

Aufgrund zu geringen Speicherplatzes kann es bei der Arbeit mit umfangreicheren Klassen zu Fehlermeldungen und Programmabstürzen kommen. Meine Fähigkeiten und Kenntnisse reichen leider nicht, um dieses Problem grundlegend zu beheben, ohne dabei die Geschwindigkeit beim Arbeiten mit dem Programm zu beeinträchtigen.

Aus diesem Grunde muss ich also Palm OS 5 als Systemvoraussetzung für die aktuelle Version festschreiben.

An dieser Stelle kam mir die Idee, hier doch eine Liste von kompatiblen Geräten zusammenzustellen. Also solche Geräte, auf denen mein Programm zuverlässig läuft (von den kleinen Programmierfehlern abgesehen). Für Nutzer, die auf der Suche nach einem geeigneten Programm sind, wäre dies vielleicht hilfreich.

Wenn Sie also mit meinem Programm arbeiten, mit der Funktionsweise zufrieden sind und Ihr Gerät noch nicht hier aufgeführt ist, schreiben Sie mir bitte eine Mail.

Danke


Liste der kompatiblen Geräte:
  • Palm TX
  • Sony Clie TG 50 (keine Zusammenarbeit mit der erweiterten Kontakt-Datenbank)
  • Palm Tungsten T5
  • Palm Tungsten T3